Jens Segers on Apr 29 2016

List outdated composer packages

It has been more than a year since I opened a GitHub issue on the composer repository to propose an outdated command. It took a while, but we finally got what we asked!

Vincent "Vinkla" Klaiber wrote a great blog post about how to use the new command with all available flags, go check it out: https://medium.com/@vinkla/find-outdated-packages-with-composer-968828c1d80a

Because I was using Vinkla's climb package (now deprecated) as an intermediate solution to this problem, I made myself a bash alias replacing the climb command with the new composer command:

alias climb="composer outdated --outdated --direct"

Thanks @barryvdh for making it happen!


Comments

rehan manzoor 6 months ago

thanks!